Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a simple setup.

  1. Server at home has local I.P. 192.168.1.3
  2. IIS is running on the server and the website is up.
  3. Windows firewall on the server has an exception rule for port 80 TCP
  4. Router has static I.P. XX.XXX.XX.XXX
  5. Router is forwarding TCP port 80 to 192.168.1.3
  6. My domain registrar is my DNS host and is pointing to the static I.P. XX.XXX.XX.XXX of the router

Here's what I can and can't do.

  1. I can browse the website from within my home network either by I.P. or domain name.
  2. I can ping the domain and the I.P. from outside the network (from a computer at work).
  3. I can't browse the website either by domain name or by I.P.

Wierd. Why I can't browse my website?

share|improve this question
    
What happens when you try to browse to the domain? Do you get a timeout, or, is it an IIS error message? Is it possible your ISP is filtering traffic on 80? –  Andrew Taylor Feb 1 '11 at 19:22
    
Please see: meta.stackoverflow.com/questions/9686/… –  Mark Henderson Feb 1 '11 at 19:38
    
Sorry Mark. I originally asked this at StackOverflow, and didn't find any questions that duplicated mine at the time. Do you have a wiki question that merges all these together to make some sort of one-stop-shop for those of us who want to host at home? –  Richard DesLonde Feb 1 '11 at 20:36
    
Seems like a strange question to ask on SO and it should never have been moved to SF. The option to move it to where it belongs, SU, is not available to us now. –  John Gardeniers Feb 1 '11 at 21:13
    
Not sure why it would have belonged on SU. Unfortunately we can't get them all right. Life goes on, I guess. –  Richard DesLonde Feb 2 '11 at 2:37
add comment

migrated from webmasters.stackexchange.com Feb 1 '11 at 19:18

This question came from our site for pro webmasters.

3 Answers

There's always the chance your ISP is blocking traffic on port 80. You could try it on something like port 8080 to see if the traffic gets through then. Bear in mind that your ISP may be blocking port 80 because it's against the TOS to host a website - in this case, hosting your site on port 8080 might work, but you are at their mercy if it's specifically against their terms of service to do so.

share|improve this answer
add comment

Not sure about IIS myself, but a logical thing to check:

Make sure IIS isn't listening on localhost/127.0.0.1 or an internal IP. Should be listening on either 0.0.0.0 (all interfaces) or your static external IP. (not a networking major here so not 100% sure on routing issues)

Hope this helps.

share|improve this answer
add comment

The router's firewall and other protection software was enabled. Comcast forgot to disable this when they gave me a static I.P.

I called them and they disabled it and put the router into "pass-through" mode, and voila, website is browseable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.