Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get WDS to PXE boot some laptops. The university is running a (linux) DHCP server for the entire network; we can't run our own. We can (and have) set options in that DHCP server to point to a tftp server and file (pxeboot.n12 on the WDS server we run). The client seems to get the pxeboot.n12 file (judging by the server logs), but then comes back with 'TFTP download failed Pres any key to reboot'. I've tried running a third-party tftp service on the WDS server, and found that the client pulls the first stage (pxeboot.n12) correctly, but then looks for the second stage (bootmgr.exe) in the root of the tftp folder - whereas WDS places it in \boot\x86\ (or \boot\x64). Similarly, it looks for a file called BCD, which doesn't exist (rather there are a few files scattered around with the extension .bcd). I'm confused if the WDS tftp server does some magic returning certain files, or if I haven't configured it correctly.

The server is 2008 R2.



share|improve this question
What kind of network card is in the client? Have you tried other client types? – Nic Feb 2 '11 at 6:37

Can you put the bootmgr.exe in the root of the tftp folder?

share|improve this answer
Have tried this - in the WDS TFTP server, file access is restricted to certain folders (specified in a reg key - I think it's /boot mostly). this can be worked around, but I assume there's a reason for it and it should work without having to hack the reg. With the third party tftp server, I tried this as well, and it picked up the bootmgr.exe, but then failed on some other files (e.g. BCD) – askvictor Feb 2 '11 at 20:53
up vote -1 down vote accepted

Worked it out; there was some DHCP strangeness going on. PXE is a fickle beast.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.