Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This morning, my ISP has changed the ftp port. Now it is working through 10829.

In port 21, we have a lot of scans, and the last week, the server had a brute force attack.

In the ptoftpd.log, the connection is successful, but in the ftp client, the connection doesn´t work

I have this error in the ftp:

Connection established, waiting for welcome message...
Reply:          220 ProFTPD 1.3.1 Server () [::ffff:X.X.X.X]
Command:    USER xxxxxx
Reply:          331 Password required for efetepero
Command:    PASS ******************
Reply:      230 User efetepero logged in
Command:    OPTS UTF8 ON
Reply:          200 UTF8 set to on
Status:     Conectado
Status:         Recuperando el listado del directorio...
Command:    PWD
Reply:          257 "/home/data" is the current directory
Command:    TYPE I
Reply:          200 Type set to I
Command:    PASV
Reply:      227 Entering Passive Mode (X,X,X,X,203,146).
Command:    LIST
Error:  Connect time out
Error:  Failed to retrieve directory listing

When the port 21 was configured, the ftp worked without problems.

In the connection with notepad++ by ftp, I list the directory, but i don´t see any file

I see that the ftp client work in the pasive mode,but in the protpd.conf doesn´t configure this opcion( i only change tie port)

Best regard

share|improve this question

1 Answer 1

Looks like your ISP has also filtered the TCP ports for passive connections.

They should limit the passive port range with the conf option

PassivePorts            60000 60199

That'll limit passive ports to 60000 to 60199

Then once the passive ports are limited just open the ports on the firewall corresponding to that range

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.