Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Red Hat Linux 5.4 on HP DL580 server with 16 processors and 64 GB of RAM. I'm connecting to the server remotely through SSH. after entering the password, it takes time to return the command line, if I click ctrl+c during this time, I'll have the command line prompt but not the correct bash prompt (I have to run bash to pass to my correct prompt).

I tried to install Apache on the server, ./configure took 4 hours to finish instead of 1 or two minutes, Oracle installation same behavior.

Server Disks are mirrored using RAID controller.

any idea what could be the reason of this slowness?

I was checking the read speed on this server and it seems too slow 2.58 MB/sec:

[root@server ~]# hdparm -t /dev/cciss/c0d0p2

 Timing buffered disk reads:    8 MB in  3.11 seconds =   2.58 MB/sec
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Inappropriate ioctl for device`

I have installed the RAID controller driver from HP website but didn't resolve the issue.

nothing wrong in .bashrc, and "source .bashrc" will run quickly (.bashrc is not executable to run ~/.bashrc !).

[user1@myserver ~]$ cat .bashrc c
# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
  . /etc/bashrc

# User specific aliases and functions

any suggestions?

share|improve this question
It sounds like either you've got serious network issues, disk issues, or the server is under intensive load. Have you checked top? Have a look for anything out of the ordinary in dmesg and see if you've got some RAM free with the second row of free -m. Also, try running a command that takes ages to response with "time" in front of it to see if it's not just a network delay. On the whole, I'd suggest asking Red Hat support to take a look (I think their support covers this but I'm not sure). – James L Feb 2 '11 at 20:25
up vote 2 down vote accepted

The login delays are probably an issue with DNS lookups. Try logging in and typing w | grep your-username to view your source IP address or hostname. Placing a quick entry in /etc/hosts to map your source IP to a name will help determine if this reverse lookup is the source of your login delay.

The better long term solution is to check what this system has for DNS entries in /etc/resolv.conf and make sure your source address is resolvable.

For the compilation issues, can you get a quick snapshot of the system load at the time? Run uptime or top to get a feel for the load average.

share|improve this answer

We have changed the power profile on the HP DL580 G7 server from “Balanced Power and Performance” to “Maximum Performance”. and the issue was solved!

This option enables the user to select the appropriate power profile based on power and performance characteristics. The following options are available: 1. Balanced Power and Performance provides the optimum settings to maximize power savings with minimal performance impact for most operating systems and applications. 2. Minimum Power Usage enables power reduction mechanisms that may affect performance negatively. This mode guarantees a lower maximum power usage by the system. 3. Maximum Performance disables all power management options that may affect performance negatively. 4. Custom provides the opportunity to configure settings for your environment.

Others advised to delete the RAID configuration created by default by this server from BIOS and recreate it as it was and the issue will be solved.

Thanks for you support.

share|improve this answer

Do you have something suspicious in your bashrc? E.g. how long does

. ~/.bashrc


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.