Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently trying to set up a small storage system as a fibre channel target. This is for testing, so I'm currently using Solaris (Nexenta) and a QLogic QLA2340 HBA.

For some reason, the qlc and qlt drivers don't support the QLA2340, so I'm using the qla2300 driver from QLogic's website. I've also got the scli utility installed for configuration. The HBA is detected by the system.

That said, it's not clear how I get from this point to a point where I have a ZFS volume being exposed as an FC target. I was originally following this guide (http://www.youtube.com/watch?v=yzEBd3l7Qn4) but it seems that without the qlc/qlt drivers, Sun's configuration tools won't work. Does that also imply that COMSTAR also won't work?

What's the best way to expose an FC target with this setup? Most of the options I'm seeing in scli complain that the port state is LinkDown (it is, I've not plugged anything in yet). Do I have to have my FC client plugged up and working before I can configure the target?

Apologies for the slight vagueness of the question, but I'm not overly familiar with the terminology.

share|improve this question
add comment

2 Answers

Basicly you need to make FC availible before the volume can be detected, also Solaris usualy use qlc driver for SAN, and check the QLA2340 firmware with scli utility. Then reboot the server with a "reconfiguration", the SAN connection show be seen at this point by command:

# cfgadm -al

share|improve this answer
    
One of the problems I had was that the 2GB QLogic cards aren't supported by the qla/qlc drivers, and I had to use a driver from the QLogic site (qla2300 I believe). In the documentation, they mention that for this particular driver, they hard code target mode to be 'off'. It looks like it just doesn't work for that hardware / OS combination. I'll buy an Emulex LP instead :) –  growse Mar 15 '11 at 9:45
add comment
up vote 0 down vote accepted

Right, as per the previous comment, I figured it out, so thought I should answer this.

Short answer: you can't.

The Solaris qla/qlc drivers do not support the QLogic 2GBit fibre cards. They just plain won't see them in any capacity, initiator or target. The only way to get the OS to be able to use the cards is to grab QLogic's qla2300 driver on their site. From the Readme:

Hard-coded NVRAM values
The following firmware option values are hard-coded in the driver:
1. Enabled Node Name option. 
2. Enabled Full Login after LIP. 
3. Disabled Stop PortQ on Full Status. 
4. Enabled PDBC notify. 
5. Enabled Target Inquiry Data for disabled LUNs. 
6. Enabled ADISC. 
7. Disabled Disable Initiator Mode. 
8. Disabled Enable Target Mode. 
9. Enabled Fairness in loop arbitration.

So it won't work. Because they disabled it in the driver.

share|improve this answer
    
Well that's outright depressing! I'm trying to do the same thing (OpenIndiana <-> Solaris 11) with the same cards. Did you manage to get IPoFC working at the very least? Get some iSCSI going? –  RandomInsano Jun 10 '12 at 7:05
    
Never tried IPoFC. I just bought an Emulex 2GB card instead. Works great. –  growse Jun 10 '12 at 10:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.