Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I wanted to set up a small wireless network, and in order to save some cash, had a look in the basement... where I found an old Speedtouch 580 router. However, I'm currently having loads of trouble actually configuring it. It's been used (obviously), and it seems like some default settings have changed - most manuals list its configuration screen's IP address as being either 192.168.1.254 or 10.0.0.138, but none of those get me a connection. Strangely, 192.168.1.1 gets me a Draytek login screen... probably some other router on the network, so nvm.

So: is there a way I can find out where the configuration screen has moved? Resetting the router hasn't helped noticeably...

Thanks a bunch!

share|improve this question
    
When trying those IP addresses, did you also change the local IP address on your computer to be in the same /24 subnet? –  Nic Feb 3 '11 at 1:14
add comment

3 Answers

You can try connecting it to a spare interface with a crossover cable, and do a network capture on that interface. Look for arp traffic, or maybe DHCP requests. That might get you started. It might arp and give away its address as it boots.

share|improve this answer
    
What he said. If it's really old you will need the x-over cable. Otherwise a straight through will work. I usually use tcpdump on the interface, and when I see the arp requests I can usually tell what the ip is. Then you just need to put yourself on that network and log in. I have done this many times to configure ata's. Good luck! –  Nathan Powell Feb 3 '11 at 2:28
add comment

Try pressing the reset button on the back of the router and holding it for a few seconds as it powers on. This should reset everything on it to defaults (which you might need to do anyway even if you do find it as the password is probably changed).

share|improve this answer
    
Agree, should be able to get DHCP after the reset via a wired connection. Manual is here on how to reset & the default settings. If the reset doesn't work then maybe that's a sign of why it was required. speedtouch.net.nz/Documents/ST580/Users%20Guide%20580.pdf –  Ed Fries Feb 3 '11 at 1:24
    
I did so a few times already, actually... it did reset the wi-fi settings so I can connect wirelessly now, but there's no way for me to configure a password for it :-( –  JorenB Feb 3 '11 at 1:41
add comment

Since the router is a gateway for your network, most likely you can just run ipconfig (Windows) or ifconfig (Linux), find the gateway address, then just type that into your browser. If you get a website, your in your routers configuration page.

Rarely has this not worked

share|improve this answer
    
He stated that there is another router on the network. Systems will try to obtain their last IP when doing a DHCP request. The DHCP server which gave that IP previously out will answer immediately so he wont get an IP from the router he's trying to find. –  Patrick Feb 3 '11 at 1:16
    
It lists 192.168.1.1 as the default gateway, but the router is definitely not a Draytek... strange? –  JorenB Feb 3 '11 at 1:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.