Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Actually I found these reports in server's mail queue. It repeats everyday i find 3 mails...

2 from Cron Daemon

[cpbackup] Backups are not scheduled to run today (This can be adjusted in WHM => Backup => Configure Backup)

// i dunno why i see this as just weekly backups which executes in fridays is enabled

etc/cron.daily/logrotate:

error: conman:21 error verifying olddir path /var/log/conman.old/: No such file or directory

error: found error in file conman, skipping

And there is a logwatch mail which is very long.

that started like 1-2 weeks ago

anyone can explain what happens ?

Thank you

share|improve this question
    
can that be about cPanel automatic update ? –  RULE101 Feb 3 '11 at 3:26

1 Answer 1

up vote 1 down vote accepted

Those all look like standard system-generated messages. For example, logwatch is installed on most modern linux servers by default. It looks through all the logs on the machine and sends a nightly email about what's going on on the system.

The logrotate message about conman is just telling you that /var/log/conman.old doesn't exist. From the logrotate man page:

   olddir directory
          Logs are moved into directory for rotation. The  directory  must
          be  on  the  same physical device as the log file being rotated,
          and is assumed to be relative to the directory holding  the  log
          file unless an absolute path name is specified. When this option
          is used all old versions of the log end up in  directory.   This
          option may be overriden by the noolddir option.

so just create that directory as root (sudo mkdir /var/log/conman.old) and those messages should stop as logrotate will then be able to rotate old log files into the directory.

You should be able to adjust the WHM backup messages through the cpanel interface to your server.

If you don't want to see the logwatch messages, just move the file /etc/cron.daily/0logwatch out of the cron.daily directory to stop the nightly logwatch processing. I would however encourage you to actually inspect these messages occasionally to keep an eye on what is going on with your server.

These messages all look relatively normal. Once you fix the logrotate error you should be fine.

share|improve this answer
    
thx for that great explanation. –  RULE101 Feb 4 '11 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.