Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hello My server is Ubuntu LTS 10.04 Installed and configured postfix with sasl, courier and virtual domains with mysql behind them. everything is working except for sending of email to outside domains.

here is the configuration

here is the verbose smtp log of an unsuccessful send.

I'm testing this from squirrel on the same server, and can't actually test form outlook since my local ISP is blocking outside smtp connections on port 25.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It looks like Squirrel did not authenticate to your Postfix server using one of the login mechanisms. It's OK since you were already authenticated to Squirrel, you should just correct your Postfix config a bit. You should set mynetworks to 127.0.0.1 to allow Squirrel to send emails, like this:

mynetworks = 127.0.0.0/8

share|improve this answer
    
Ok, this worked for sending from squirrel, How can I test to see if sending from an outside client will work? problem is my isp blocks outgoing to port 25 –  cromestant Feb 3 '11 at 11:54
    
also, why didn't the mynetworks = all work? –  cromestant Feb 3 '11 at 11:55
    
I don't think all is a proper configuration value for mynetworks, it should be 0.0.0.0/0 if you want to enable any IP to send email through your MTA. Actually, you don't want to enable anyway, because setting it to 0.0.0.0/0 will effectively turn your MTA to an open relay. That's not a good idea since every spammer will be able to utilize your open relay to send SPAM. It's better to leave mynetworks set to 127.0.0.0/8. –  Alex Feb 3 '11 at 12:06
    
You can test sending from an outside using a port different from 25 temporary. Ports are configured in /etc/postfix/master.cf The default port is defined in this line: smtp inet n - - - - smtpd You should change the first smtp to some other numerical value, like this:1025 inet n - - - - smtpd (It will use port 1025 then) –  Alex Feb 3 '11 at 12:09
    
ok thank you for your explanation. –  cromestant Feb 3 '11 at 12:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.