Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 7 desktop on which I've installed Windows Virtual PC and an instance Windows 7.

I also have virtual XP instance on the same host. The problem I am having is that copying files from the host to the virtual machine is dog slow. I'm talking 17KB/sec. The host machine has a gigbit NIC.

While using the XP virtual instance to do the same I didn't notice a huge difference but on the Window 7 virtual instance the time is really slowing me down.

Is there something I need to do (settings) to fix this?enter image description here

I've attached an image of the Resource monitor (of the virtual Windows 7 instance) that shows my network traffic going in bursts rather than relatively steady. The files are on a "public" folder on my host machine.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Ive seen this with dynamic disks. You might want to put your virtual machines in fixed size disks, I think theres an easy way to migrate from fixed to virtual but its escaping me at the moment.

The other thing to check would be that the integration components are properly installed, a removal/reinstall might be in order.

share|improve this answer
    
@Ernie I'll try setting the disk to fixed size. I'm currently installing someone on the VM and once I'm done I'll get a handle on the size I can set it to. As regards the integration components in the Settings windows, Integration Features says Not Available. And in the Tools menu when I click on Install Integration Features, nothing happens. –  Shiv Kumar Feb 3 '11 at 14:33
    
Oh yeah, fix that before you do anything else. Once you fix the ICs you'll probably be fine. Without the IC functioning you're performance goes WAY down on everything. –  ErnieTheGeek Feb 3 '11 at 14:37
    
@Ernie, the fixed size didn't help. The files transfered at the same rate even on a fresh virtual machine. I did find that internet transfers are almost normal speed and since I a really fast Internet here, I upload to an ftp site from the host and download it from th ftp site on the VM and I'm now able to move files in less then a minute as compared to almost 3 hours. As regards the IC thing, I'm not sure where/how to fix it. for Window 7 VM I don't see any info. –  Shiv Kumar Feb 3 '11 at 18:44
    
1. Make sure your user account has a password, the ICs wont load without it, 2. Remove the ICs by using the add/remove software control panel. 3. Reload them by leaving full screen mode, click tools at the top of the screen, and it should give you the option to "Insert Integration services Disk" if you dont get the option then you can manually mount the iso. Its usually stored in C:\Windows\winsxs\x86_microsoft-virtualpc-additions_{random hash}. –  ErnieTheGeek Feb 3 '11 at 19:00
    
@Ernie, I have a user account with a password on the guest operating system (window 7). I don't see ICs in the add/remove (uninstall programs) control panel window. Well before our conversation in tried the Tools | Install ICs menu but nothing happened. Don't see the Inert Integration services disk either so I'll look at mounting the iso manually. I'll let you know how it goes. Thanks for the help and for taking the time. –  Shiv Kumar Feb 3 '11 at 19:33

For me the issue was segmentation offloading.

The solution from here worked for me... (I know the article states Virtual Server 2005 ; but this fix the issue for me in Virtual PC on Win7) http://support.microsoft.com/kb/888750

Basically on the host computer:

  • Run Registry Editor (regedit.exe) and select the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  • Create new DWORD value named DisableTaskOffload and set its value to 1.
  • Restart the host computer.
share|improve this answer
    
It's worth noting that you can disable it for the just the nic (via several "offload" properties) as opposed to the whole machine (via registry). The linked kb explains it as the last option. –  Praesagus Feb 16 '13 at 22:37
    
This solved the problem for me. Thank you. –  Big Joe Mar 11 at 11:02

You might take a look at this solution. It's due to some network parameter setting. I've applied this on a couple of PC's now and it cures the sloth every time.

Would you not thing though that all of these Microsoft products would coexist?!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.