Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Win2K3 server that is perpetually stuck on the following update:

Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86

It fails every time, and I'm at a loss on what to do about it.

WHAT I'VE TRIED:

  1. Saw an article that said to turn off the update service, rename C:\Windows\SoftareDistribution\ and then restart the update service. Did this, ran the update, and it failed on this same one.

  2. I tried to run the update manually at C:\Windows\SoftwareDistribution\Downloads\Install\ and again it fails. Says, "None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup."

Because of this issue, none of the previous updates will work either. I will give one large pink-glazed donut with sprinkles to anyone who can help me slay this beast.

share|improve this question

1 Answer 1

Check through C:\Windows\kb951847.log file. It should give you detailed reason for the error.

share|improve this answer
    
There is no logfile for this kb number - I looked carefully. However, in C:\WindowsUpdate.log, I find this: "WindowsUpdate Failure Content Install Installation Failure: Windows failed to install the following update with error 0x80070643: Security Update for Microsoft .NET Framework 2.0 SP2 and 3.5 SP1 on Windows Server 2003 and Windows XP x86 (KB2418241)." I'm a little confused by that kb number though. –  Ducain Feb 3 '11 at 16:34
    
Have you checked for C:\windows\KB2418241.log file? As well, try to download update manually. –  Vick Vega Feb 3 '11 at 19:35
    
Vick, there is no logfile for that kb. I downloaded that update manually just now and tried to run it - same error as before "None of the products that are addressed..." (see above). –  Ducain Feb 4 '11 at 15:02
    
How about trying this. Run the install again, then scan C:\ drive for the file modified slightly after you started the install, what we trying to find is the log file that the installation creates when it tries to install the update. –  Vick Vega Feb 4 '11 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.