Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A few users of our ASP.NET app (recently updated to ASP.NET 4.0) have reported receiving page-hangs in Google Chrome - specifically the Chrome error:

This webpage is not available. Error 7 (net::ERR_TIMED_OUT): The operation timed out.

The users state that other sites are just fine - it's just ours that is giving them trouble - and when they try other browsers with our app (e.g. FF/IE), those browsers are fine.

We of course questioned their installations of Chrome (version? / viruses?) - this is what all the Google Chrome forums speak of regarding this error and hangs.

We decided to do some testing of our own, and low-and-behold, we intermittently received the "Error 7" in hitting our production app under Windows 7 and the latest version of Chrome (no extensions installed).

At the precise moment that we received the error, we tried hitting the app with IE/FF - and they were fine.

Also, according to our analysis of our web logs, when we received the "Error 7", our web server (IIS 7.5 under Win 2008 R2, fully patched) did not receive the HTTP request from Chrome.

So to us, the mystery is why Chrome periodically cannot establish an HTTP connection to our web server - while other browsers have absolutely no trouble.

I know that this is a nebulous scenario, which we cannot consistently reproduce. But if anyone has some thoughts as to what we could look into - or some further tests that we could try, this would sure be appreciated.

UPDATE:

In our testing, the issue seems to be greatly remedied by going (in Chrome) to Options > Under the Hood > Network > Change proxy settings... > LAN settings, and ensuring that "Automatically detect settings" is not selected. This solution was found on one of the Google forums.

share|improve this question
    
Is this site using SSL? –  Tatas May 25 '11 at 18:19
    
Yes - it's SSL only. –  Dave Clausen May 26 '11 at 11:49

2 Answers 2

up vote 0 down vote accepted

That's a strange one. You may need to check before IIS using a tool like Wireshark. I had a fairly similar issue recently although it wasn't browser based. Our Broadcom network adapters were dropping some packets under heavy load as soon as it arrived on the server. I had to use Wireshark to prove that the requests were dropped right at the network card. A driver update mostly fixed the issue although we eventually swapped out the NIC completely.

Check any firewall IPS policies too in case they don't like the Chrome browser agent for some reason.

share|improve this answer
    
Thanks Scott - will indeed follow your advice. –  Dave Clausen Feb 7 '11 at 16:00

Try running the following switch at command line on chrome.exe.....

–disable-ssl-false-start

We've had some issues with a few SSL sites because of that draft spec "feature" that chrome chooses to include.

share|improve this answer
    
Thanks Tatas - we'll do a little testing with this. –  Dave Clausen May 26 '11 at 17:12
    
Tatas, "--disable-ssl-false-start" indeed seems to help! Now the question is how to get our users to do this. :| I've posted a message at forums.iis.net/t/1178938.aspx asking Microsoft to please look into optimal support for SSL False Start in IIS7. –  Dave Clausen Jun 9 '11 at 4:32
    
Glad this helped. Can you mark this as answered. –  Tatas Jun 9 '11 at 17:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.