Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

windows-server-2003, IIS 6, ASP.NET 4, Documents Tab, Default.aspx not being loaded, 404, Server Error in '/' Application

The only file listed in the documents tab is default.aspx.

When I browse directly to https: //server/default.aspx it works just fine. When I browse to https: //server/ I get the following error.

The behavior is the same when I vists https: //server/Login/default.aspx/ | https: //server/Login/

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /Login/

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

The server log look like this:

2011-02-03 19:33:27 W3SVC2034766641 205.119.126.64 GET /Login/default.aspx - 443 - 205.119.126.60 Mozilla/5.0+(Macintosh;+U;+Intel+Mac+OS+X+10_6_6;+en-us)+AppleWebKit/533.19.4+(KHTML,+like+Gecko)+Version/5.0.3+Safari/533.19.4 200 0 0
2011-02-03 19:33:35 W3SVC2034766641 205.119.126.64 GET /Login/ - 443 - 205.119.126.60 Mozilla/5.0+(Macintosh;+U;+Intel+Mac+OS+X+10_6_6;+en-us)+AppleWebKit/533.19.4+(KHTML,+like+Gecko)+Version/5.0.3+Safari/533.19.4 404 0 0
2011-02-03 19:37:42 W3SVC2034766641 205.119.126.64 GET / - 443 - 205.119.126.60 Mozilla/5.0+(Macintosh;+U;+Intel+Mac+OS+X+10_6_6;+en-us)+AppleWebKit/533.19.4+(KHTML,+like+Gecko)+Version/5.0.3+Safari/533.19.4 404 0 0
2011-02-03 19:37:48 W3SVC2034766641 205.119.126.64 GET /Login/default.aspx - 443 - 205.119.126.60 Mozilla/5.0+(Macintosh;+U;+Intel+Mac+OS+X+10_6_6;+en-us)+AppleWebKit/533.19.4+(KHTML,+like+Gecko)+Version/5.0.3+Safari/533.19.4 200 0 0
share|improve this question

1 Answer 1

up vote 2 down vote accepted

http://stackoverflow.com/questions/2635320/asp-net-4-0-default-aspx-problem-on-iis6

Found a fix in a seemingly unrelated location - try setting the "EnableExtensionlessUrls" registry key to 0:

ASP.NET 4 Breaking Changes -> ASP.NET 2.0 Applications Might Generate HttpException Errors that Reference eurl.axd:

In the Windows registry, open the following node: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET\4.0.30319.0

Create a new DWORD value named EnableExtensionlessUrls. Set EnableExtensionlessUrls to 0. This disables extensionless URL behavior. Save the registry value and close the registry editor. Run the iisreset command-line tool, which causes IIS to read the new registry value.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.