Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 machines - a windows 7 and an opensuse server. they both use the same router.

I noticed when setting up xrdp (remote desktop), I could only remote desktop into my opensuse 11.3 machine from my windows 7 machine when I was logged into the opensuse machine locally (tried as both my user account and root).

I remoted in, and was logged in locally already, so I logged out locally, and it killed my remote connection.

Also, when I ping the openususe IP from windows machine, I only get a response back when I am logged in locally to the opensuse machine. How do I fix this? I have not setup up an networking with samba or anything

share|improve this question

1 Answer 1

Chances are very high your OpenSUSE install is set up to use NetworkManager to manage networking connections, which is a userspace tool. If you want OpenSUSE to be on the network without a logged in user, you need to:

  1. Go into YaST
  2. Go to Network Settings
  3. Go to the "Global Options" tab
  4. Check "Traditional Method with ifup"

That will set it up to get a connection on boot, instead of on-login.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.