Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a problem with enabling roaming profiles.

I have a test user ittest. I went into their AD account and changed the roaming profile location to \servername\profiles$\ittest

The profiles folder is shared out, and everyone has full permissions on the share level. On the NTFS level it looks like this. Domain users and servername\users both have FULL permissions (I know this is bad but I’m trying to troubleshoot) inside of that folder I have a folder named ittest where the users profile should redirect. I made it and they have full permissions. When I log out and the profile tries to write to the server, I can see the folders being created but I will get a message saying can’t write this file (a normal DOC file I think it’s the first one it reaches) access denied.

If I log in as ittest I can browse to \servername\profiles$\ittest and can write and read to the subfolders that have been created. So I’m totally stumped.

share|improve this question
    
Did you create the user folder or did you let Windows create it. The best practice method is to let Windows create it. Have a look here: technet.microsoft.com/en-us/library/cc737633(WS.10).aspx –  joeqwerty Feb 3 '11 at 22:10

2 Answers 2

Windows is very particular about the access rights to profile folders; you should let windows create them, or study an existing profile and figure it out for yourself (handy when setting up a samba server for profiles :-) ).

share|improve this answer
    
I still am having trouble, I have followed many guides but am not having much luck, do you have any comprehensive reading you could recommend? –  Will Feb 8 '11 at 16:06
    
Something is up, I just redid this completely. Deleted the share , created a new one named Profiles, gave full control to everyone on the share level and it still is giving me access denied. I told it to create the profile in \\server\profiles\ittest (letting it create the ittest folder. It does create the profile folder, but I can't even access it now. I have no idea whats going on. –  Will Feb 8 '11 at 16:30

Just make a Roaming folder in c drive and share it with every one. After then go to ADUC and make user and provide the path like this \server name\share folder name\username After then open the MY Computer properties Go in Advance Setting and then in User Profiles click on Setting button. After that paste that path \server name\share folder name\username in copy to After then first login on server machine to activate the account and then login in user computer it will work.

Thanks and Regard Divya Ranjan. Certified MCITP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.