Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I Apache and PHP 5.3 installed from Blastware. I run

pecl install apc

and everything went ok. is in the extension library. I declared the extension in php.ini and enabled it with 'apc.enabled=1'.

Apc it is still not loaded, not showing in phpinfo(). Why?

Of course I restarted Apache2.

share|improve this question

1 Answer 1

I'm not sure about Solaris, but Linux uses two separate php.ini files for Apache's mod_php and command-line php. They are located at /etc/php5/apache2/php.ini and /etc/php5/cli/php.ini respectively. Probably Solaris uses two PHP configuration files too. You should check this using find /etc -name "php.ini"

share|improve this answer
Why I should border about the command line? I am sure the extension is declared for the mod_php part. – rtacconi Feb 5 '11 at 10:47
php.ini is only one – rtacconi Feb 5 '11 at 11:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.