Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When using vim under screen, some keys are not working.

Namely, Pressing Alt-Left produces '3D' and Alt-Right produces '3C'

Also, pressing Up/Down when scrolling list of files in Command-T plugin produces 'A' and 'B' respectively.

When I exit the screen and run vim just under ssh session, all works fine.

Are there any settings in screen itself or terminal server/client I can tweak to fix this issue?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Modify your .screenrc section

term xterm

Or modify your .vimrc:

if match($TERM, "screen")!=-1
  set term=xterm
endif

For more information, see vim.wikia.com

share|improve this answer
    
Thanks heaps, that worked! –  Art Feb 5 '11 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.