Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed EasyPHP so as to have an Apache web server with PHP and everything included. This works like a charm when I access it by browsing to http://127.0.0.1:8888/, but unfortunately it fails when I go to http://192.168.x.x:8888/ (where x is my computer address in my local network). In Chrome, I get the following error:

Error 102 (net::ERR_CONNECTION_REFUSED)

What I've tried:

  • I am able to ping to my computer using ping 192.168.x.x.
  • I've added an exception to Windows Firewall so as to let it pass requests to the 8888 port, to no avail.

Would anyone possibly know what could be the cause?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Try add "Listen 192.168.x.x:8888" to Apache conf and edit VirtualHost:

<VirtualHost *:8888>
share|improve this answer
    
I changed the Listen directive to just Listen 8888 and it was all working, thanks. –  pimvdb Feb 5 '11 at 17:02

It's probably caused by the Apache settings for the directory where your files are kept. Open httpd.conf and check the <Directory "c:/where_is/easy_php_installed/www"> part

if the content is:

Order Deny,Allow

Deny from all

Allow from 127.0.0.1

change it to:

Order allow,deny

Allow from all

share|improve this answer
2  
And is the listen directive in the httpd.conf Listen 8888? –  addam Feb 5 '11 at 16:48
    
No it wasn't - sorry I'm a very beginner. –  pimvdb Feb 5 '11 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.