Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a Unix/Linux/Windows Server noob. So, keep that in mind before you throw your stones at my glass house. :P

I have a Windows Server 2008 R2 machine that's acting as domain controller, Server A. It's also running a DNS server. I have a Red Hat Enterprise Linux Server 5.3, Server B that is intended for mail server.

In order for the mail delivery to happen, I understand that I have to set an MX record on Server A and point it to Server B. Well, I did. I manually added a host name on Server A and pointed to Server B's IP address. Then I added an MX record and pointed it to the host name. That didn't do the trick. After taking the above steps, I used the "dig" command on Server B to lookup the MX record coming back from Server A and it wasn't what I was expecting.

What am I doing wrong here?

I have noticed that... my Windows machines that are joined to the domain (Server A) are listed under the host names. The machines that are not joined to the domain are not list. This is fine, I am not worried about this. What does concern me, do I have to join the Server B to domain in order for Server A to recognize as a valid host and forward the MX properly? If so, some simple steps on how to join Server B to the domain would also help.

Additional Details:

Windows Server 2008 R2 Domain controller's name: Zeus Red Hat Enterprise Linux Server's name: Mail

Forward Lookup Zone Records on Zeus:

  • mail, Host (A)
  • mail, Mail Exchanger (MX), [10]

Result from running nslookup -type=mx on Zeus (Server A):
    primary name server =
    responsible mail addr = (root)
    serial  = 0
    refresh = 28800 (8 hours)
    retry   = 7200 (2 hours)
    expire  = 604800 (7 days)
    default TTL = 86400 (1 day)
Server:  UnKnown
Address:  ::1   MX preference = 10, mail exchanger = mail

Result from running dig mx on Mail (Server B):

; <<>> DiG 9.3.4-P1 <<>> mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59592
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0


;; AUTHORITY SECTION: 105 900 600 86400 3600

;; Query time: 0 msec
;; WHEN: Sat Feb  5 22:49:12 2011
;; MSG SIZE  rcvd: 81
share|improve this question
When you "adde a host name on Server A" do you mean you added an A record for Server B to the DNS table? Then a separate MX record pointing to that A record (and possibly others) should work. – mpez0 Feb 5 '11 at 22:08
Yes, that's exactly what I meant. I added an A record for Server B and then an MX record pointing to the newly created A record. It didn't work. – Sai Feb 5 '11 at 22:30
You're saying that B gets MX record from A as seen in dig output. Are you sure A gets MX record from its own database? What happens if you do MX lookup on A? I think nslookup still is the command there. – user69660 Feb 6 '11 at 0:09
Can you give specific examples? what does the dig mx. and the result of dig result of hostname responded from the mx. Chris-Evanss-MacBook-Pro:~ cwevans$ dig +short mx 10 Chris-Evanss-MacBook-Pro:~ cwevans$ dig +short – becomingwisest Feb 6 '11 at 0:48
Chris, I added more information. I am not sure if that is what you're looking for. – Sai Feb 6 '11 at 3:51

Provided info shows that answer is coming from (is that zeus?), it is not an authoritative answer for this zone and it could not find MX record for

share|improve this answer
Yes, it is Zeus. So, how do I fix it? – Sai Feb 6 '11 at 16:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.