Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an HP ProLiant DL180 G5 server with a Smart Array E200 RAID controller. The RAID controller is refusing to recognize inserted drives as an array. The story so far...

This server (our file server) needed an upgrade. It started with 8 x 250GB drives:

  • 2 in RAID1 for the OS
  • 5 in RAID5 for data
  • 1 as a hot spare.

The plan was to replace the RAID5 array and hot spare with a RAID10 array composed of much larger disks. The old drives would be untouched in case any recovery was needed. The following process was used:

  1. Shut down server
  2. Remove drives used in data array and hot spare, and label with their positions.
  3. Boot up the server and acknowledge errors about failed drives
  4. Insert new drives and create new RAID10 array
  5. Format new array and restore data from tape backup.

This procedure worked as expected. But some data was missed in the last backup, so I need to recover data from the drives in the original array. Here's what I've done:

  1. Shut down server
  2. Remove drives used in new RAID10 array
  3. Insert old drives according to position labels.
  4. Boot up the server

At this point, I get the following error:

1785-Slot 0 Drive Array Not Configured
     Drive positions appear to have changed.
     Run Array Diagnostics Utility (ADU) if previous positions are unknown.
     Then turn system power OFF and move drives to their original positions.

I had assumed that the RAID metadata stored on the disks would be sufficient to bring the old RAID array back online, but that doesn't seem to be the case. I can hardly believe that the drives would be rendered inaccessible as soon as they are removed from the original RAID controller. Is there anything I can do to access the data on the old drives? If not, which RAID controllers support this, so I know what to buy in the future?

I have already contacted HP support, and they were unable to help. Their recommendation was to recreate the RAID array and restore the data, but that doesn't really help my situation.

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

The removed drives still have the RAID metadata on them. When you went to step #3 in the first drive replacement process; Boot up the server and acknowledge errors about failed drives, did you DELETE the removed array/logical drive or just mark it as failed? That's probably the source of the problem here.

When you brought up the system with your old drives, you should have again deleted the new data logical drive either in the BIOS raid utility or with the Smartstart/DL180 Setup Array Configuration utility and let the controller detect the array/logical drive.

Try this. Boot up with the new drives removed. Go into the BIOS or DL180 setup disk Array Config and delete the RAID 1+0 array. Then boot with your old drives and see if they're detected. Get the data you need. Remove the old drives. Delete the array. Insert your new drives. Let the controller discover the new array. Restore your data...

Keep this HP Smart Array controller users guide handy. http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01608507/c01608507.pdf

share|improve this answer
    
Yep, that was it. And thanks for the link - the E200 manual I was reading was sparse on details. –  Nic Feb 6 '11 at 0:16
add comment

Oof, this one should have been obvious.

The E200 controller was still expecting to see the drives from the RAID10 array. When I powered up without the data drives inserted, it gave a warning about failed drives instead of an error, then let me continue into the OS. Once in the OS, I was able to access the Array Configuration Utility to "delete" the RAID10 configuration. On the next reboot, the RAID5 array reappeared as expected.

I'm not sure if this question should be deleted, since I answered it myself so quickly. But I think it could be useful for other people using HP RAID controllers.

share|improve this answer
add comment

If not, which RAID controllers support this, so I know what to buy in the future?

I've had great experiences with 3ware controllers in situations like this. I've pulled full arrays from 6000 series controllers and used them on 7000 series controllers. I've intentionally jumbled the drives in an array and it picked up the changes without issue. The 3ware (tw_cli) utility is much more user friendly than either the HP (hpacucli) or the LSI (MegaMgr/MegaCLI) utility. (It should be noted that LSI bought 3ware last year. I hope they continue with the (almost) awesome 3ware utility.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.