Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got my Ubuntu server built and working, but I have to manually add a boot parameter ("no-hlt") into grub to start. I'm running maverick so it's grub2..and I can't figure out how to put it in so I don't have to manually override it on every boot. What exactly do I need to do to include this parameter in the default boot?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Edit the /etc/default/grub file:

GRUB_CMDLINE_LINUX="no-hit"

If you only need it on normal boot (i.e. not single-user mode):

GRUB_CMDLINE_LINUX_DEFAULT="no-hit"

If there are already options there, then either append or prepend (doesn't really matter which) using spaces as delimiters.


Some might say to edit /boot/grub/grub.cfg; this is a bad idea, as Grub2 automatically overwrites this file every time anything involving the kernel or GRUB is updated.

share|improve this answer
1  
Perfect, that did it. The only other step was after updating that file, was to run sudo update-grub. Thanks for the tip! –  Matt Stratton Feb 7 '11 at 4:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.