Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The error as shown in the 2 pictures below: no server specified and no default

can't ping www.p0864868.com and can't get the hostname/nslookup result

The configurations for named.conf and the zones files as shown below: named.conf

p0864868.zone file

10-0-0.zone file

Update 1: This is the result after applying the suggestions from "alveso".

The error has been resolved, but I still can't ping my own domain www.p0864868.com (10.0.0.1) nor can I do host or nslookup lookups as shown on previous pictures.

named service

I also attached my the changes that I made to my named.conf as well as my resolve.conf configs as shown below: named.conf that has been edited as suggested by alveso

Resolve.conf as reference in case you want to see it

Update 2: I turned on logging by typing "rndc querylog" with the output as below when I pinged p0864868.com rndc log

Update 3: changed permission of 10-0-0.zone and p086868.zone to 644 named:named Still can't ping www.p0864868.com or execute host command. It says something like Network Unreachable. network unreachable

share|improve this question

1 Answer 1

1 Find key-name and key-value. Open "/etc/rndc.key"

key "<key-name>" {
  algorithm hmac-md5;
  secret "<key-value>";
};

2 Configuring "/etc/rndc.conf":

key "<key-name>" {
  algorithm hmac-md5;
  secret "<key-value>";
};
options {
  default-server  localhost;
  default-key     "<key-name>";
};

3 Configuring "/etc/named.conf". Check control section:

controls {
  inet 127.0.0.1 allow { localhost; } keys { <key-name>; };
};
share|improve this answer
    
Thank you for your suggestion alvesu. Now there is no more rndc error. But I still can't ping my domain. I have attached 3 latest pictures as shown above for your reference. –  Syahmul Aziz Feb 6 '11 at 10:49
    
See bind log(host return SERVFAIL). –  alvosu Feb 6 '11 at 11:23
    
Thank you.I have enabled the logging and the output is as attached above. Sounds like it is because of permission problem? may I know what is the correct permission? –  Syahmul Aziz Feb 6 '11 at 12:59
    
depends on the file/directory, optimally named:named 644 for files. –  alvosu Feb 6 '11 at 13:06
    
ok I've changed the 2 zones files which are 10-0-0.zone and p0864868.zone to 644 named:named. But, still no progress. –  Syahmul Aziz Feb 6 '11 at 13:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.