Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.


I am trying to setup & configure OpenLDAP on Fedora Core 13. I've gotten as far as compiling and installing Openldap v2.4.23.

Whenever I try to run one of the LDAP commands (like ldapsearch), I get the following error message:

SASL/GSSAPI authentication started
ldap_sasl_interactive_bind_s: Local error (-2)
        additional info: SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more information (Credentials cache file '/tmp/krb5cc_0' not found)

I looked up on this on Google and one solution seems to be configuring Kerberos to work properly first using kinit.

However, I do not want Kerberos on my system.. is it possible to make openldap not use Kerberos at all? Do I need to compile with a suitable option ? Or is it that I MUST use Kerberos parallely with openldap ?

Thanks for your help.

Cheers,
m^e

share|improve this question
    
FWIW, GSSAPI is only one SASL mechanism. There are several others, including PLAIN. –  grawity Feb 7 '11 at 21:04

1 Answer 1

If you don't want to authenticate with Kerberos, you need to tell the OpenLDAP tools that by using the -x command line option. From the man page for ldapsearch:

       -x     Use simple authentication instead of SASL.

When using -x, you will also need -D, to specify your bind DN, and you will need to provide the password via either -W (to prompt for the password) or -y file to read the password from file.

share|improve this answer
    
So, did this answer help out? –  larsks Feb 12 '11 at 2:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.