Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don't know why my mysql doesn't read the my.cnf file. I write a commented line # skip-networking on my.cnf, restart mysqld and when exec

#ps aux | grep mysql 

returns:

root      7737  0.0  0.0   7184   812 pts/4    S+   12:20   0:00 grep mysql
root     14180  0.0  0.1  10764  1280 ?        S    Feb04   0:00 /bin/sh /usr/bin/mysqld_safe --skip-grant-tables --skip-networking
mysql    14293  0.3  3.7 396884 39364 ?        Sl   Feb04  15:27 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --skip-grant-tables --skip-networking --log-error=/var/lib/mysql/####.err --pid-file=/var/lib/mysql/####.pid

I understand the parameter --skip-networking could not be passed to mysql if it is commented on my.cnf.

Any help must be appreciate. Thanks and sorry my English

Alvaro Canepa

share|improve this question
    
What your install OS? –  alvosu Feb 7 '11 at 11:39
    
Is CentOS 5 with Plesk 9.6 (I don't know if it's relevant). Thanks. –  alvaro.canepa Feb 7 '11 at 11:55

1 Answer 1

There are a few options; perhaps that directive is in the file more than once and you only commented one instance. Perhaps the startup command adds the directive, perhaps it's pulling from more than one config file.

Can you verify that the initscript is using the config file that you want it to, by changing another directive, restarting and checking whether your change takes effect? (perhaps using 'show global variables').

Then check your startup script (/etc/init.d/mysqld?) and then grep your entire config file(s) for the directive 'skip-networking'. Unfortunately, mysql doesn't tell you where a particular part of the runtime config came from. But it looks in /etc/my.cnf, /my.cnf and ./my.cnf, in that order, by default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.