Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Update: actual answer was finally found, see self-answer below.

I have a Windows 2003 R2 machine that is giving an Event ID 8197 about once an hour and ten minutes. The full error is attached below. The machine is primary used to host IIS webpages and SMTP. There is no known scheduled tasks on the machine.

I have read a lot of Google Search and Microsoft docs, but none of the suggestions found there have any impact. What I am curious is if there is any way to convert the SRMVOLMC81 and SRMVOLMC57 into mount point data so I could at least know where the error is sourcing from (there are no related errors in the logs, just the 8197 every hour and ten).

Event Type: Error
Event Source:   SRMSVC
Event Category: None
Event ID:   8197
Date:       2/7/2011
Time:       11:32:21 AM
User:       N/A
Computer:   SERVER001
Description:
File Server Resource Manager Service error: Unexpected error. 

Error-specific details:
   Error: GetVolumeNameForVolumeMountPoint, 0x80070001, Incorrect function.


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 53 52 4d 56 4f 4c 4d 43   SRMVOLMC
0008: 38 31 00 00 00 00 00 00   81......
0010: 53 52 4d 56 4f 4c 4d 43   SRMVOLMC
0018: 35 37 00 00 00 00 00 00   57......
share|improve this question

2 Answers 2

up vote 1 down vote accepted

If this is a 2003 machine see PRB: GetVolumeNameForVolumeMountPoint API may return Incorrect Name for Volumes with Multiple Names

share|improve this answer
    
I have seen this article but it provides no pointers to patches, hotfixes or even workarounds if you didn't write the applications triggering the problem. The error message also makes it unclear what application is at fault. While we do have a lot of ASP.NET/C# code on that machine, I don't believe we have written any code that directly calls GetVolumeNameForVolumeMountPoint. –  Godeke Feb 8 '11 at 15:22
    
Basically there is no fix for 2003. This condition should only occur if the volume had been mounted by multiple copies of windows. Is thre some shared disks or was this drive previously used on another windows install? –  Jim B Feb 9 '11 at 16:18
    
The was no prior version of Windows to my knowledge... that's why it is 2003 R2, it is what it came with. However, this is a Dell with the management software partition: it might be that booting into that tool somehow mounted that partition. I'm glad to have a confirmation that there is no fix (as stupid as that seems). –  Godeke Feb 14 '11 at 20:38
    
Yes there are some issue that microsoft only addresses in future versions of windows. –  Jim B Feb 15 '11 at 2:10
    
As your answer is probably more common, I will leave this selected. I have added the actual instance I encountered as well. –  Godeke Feb 15 '11 at 15:47

As Windows still doesn't have a native ISO mount ability, I was using the Virtual CD-ROM Driver from Microsoft. This is described here: http://jamesewelch.wordpress.com/2007/08/13/mounting-an-iso-image-using-microsofts-virtual-cdrom-driver/

I used this to mount ISO files which in turn were shared across the network for deployment. As we no longer deploy any application this way I removed this tool and the error logs cleared up. No more error ever hour and some minutes.

Obviously, this driver is unsupported, but this fix would have been instantly obvious if the mount point error reported what it was trying to mount in a more usable manner.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.