Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

IIS6 is refusing to host files with a space in the name. The browser requests the file as:, which is fine. But IIS just returns a 404 for it. Replacing spaces with dashes works fine. This is a new development setup, and the previous IIS6 server hosted the files just fine, so I must be missing a setting somewhere to enable this.

Just to be explicit, the MIME types for the file are set up fine, as evidenced as when I remove the spaces and uses dashes instead.

share|improve this question

just a guess - is URLScan or something similar configured on the server and blocking the %20 -> space mapping or resulting URL?

You could test the % mapping question by getting a working url e. g. once with dashes as you said, then replace a character such as %61 for "a".

share|improve this answer
I do not believe URLScan is installed. I can't find it under the %windir%/system32/inetsrv folder, nor under Add Remove Programs. – Mortanis Feb 7 '11 at 21:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.