Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This seems to be a frequent issue of IIS users who are trying to setup php - I guess I'm not an exception here.

I followed serveral tutorials online for setting up PHP, and I am pretty sure that I have everything setup as how it should be... although accessing any php file with a browser produces a 404 error, seeming to indicate a configuration issue.

PHP 5.3.5 is sitting at C:\php\, and the FastCGI Handler is enabled as a web service extension. I have renamed the production config file to php.ini, and I have uncommented and changed the value of the cgi.force_redirect setting to equal 0.

Despite all of that, it still refuses to work.

If anyone can help, and/or provide a checklist of things that I have forgotten to mention that need checking up upon, your input would be great.

share|improve this question
    
I'm kinda surprised, I thought more people would have had issues with setting up PHP with IIS :\ –  TGP1994 Feb 9 '11 at 2:39

1 Answer 1

up vote 1 down vote accepted

Have you added php to the allowed application extensions? You should add .php as the extension and then the path to the executable. In my case it's C:\WINDOWS\system32\inetsrv\fcgiext.dll but it could be different depending on how you installed it

share|improve this answer
    
Thanks for all of the help, Mark. I'll echo what you said by saying that one should also add the string GET,HEAD,POST to the Verbs section of the extension configuration for .php. I noticed that PHP now thinks that the config directory is C:\WINDOWS, rather than C:\php, where I left the executable at. That doesn't really bother me much, since I don't plan on changing any settings. –  TGP1994 Feb 10 '11 at 22:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.