Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

CentOS running Exim 4.63(inc latest fixes).

I want to configure exim to not listen on the external IP, only localhost so that exim can only be used from the server itself (no remote connections).

What's the config option for this setup?

Thanks

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

The option you want is local_interfaces in the main part of the configuration. Section 13.1 of the spec gives some examples, and the full definitions of the option is in the alphabetical list of main options (which I can't directly link to because it doesn't have an anchor).

To summarize:

local_interfaces = 127.0.0.1
share|improve this answer
    
Thanks, works perfectly - sorry can't vote up –  user69904 Feb 8 '11 at 16:36
add comment

define interface parameter under transport section to localhost in main co

share|improve this answer
    
Tried this in the transports sectio of exim.conf and restarted exim and I'm still able to connect remotely: <code> remote_smtp: driver = smtp interface = 127.0.0.1</code> –  user69904 Feb 8 '11 at 11:22
    
This is wrong, the interface optoin sets the IP for outgoing connections –  jj33 Feb 8 '11 at 13:36
    
-1 for wrong answer –  danorton Jan 31 at 22:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.