Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm troubleshooting an issue where we no longer receive the emails that come from the form on our website. This problem started this morning after installing a SonicWall TZ-210 router but I'm not convinced this issue is related to the SonicWall router.

I have hMailServer setup on our SBS 2008 box (with Exchange Server 2008). This instance of hMailServer acts only as an SMTP relay. It allows me to put our customer's email address in the From and ReplyTo fields (using ASP Classic) so that our users can reply directly to the email. There are no MX records that point to this instance of hMailServer since it is only used internally by our IT department for a few "no-reply" type tasks.

For example, you visit our website and fill out our contact form with your email address. The contact form sends the email to sales@ourdomain.com (which is an exchange account) by authenticating with a valid account on our hMailServer.

I'm looking at hMail's logs and it processes the email without any problem so the original email sent from the website through hMailServer is making it past our router. Somewhere between hMailServer and Exchange Server the email appears to be getting lost.

We are using Microsoft Forefront Security for Exchange and I don't see anything in there that indicates that Forefront Security is getting rid of these emails. I have ForeFront Security configured so that it does not delete or reject any emails but rather flags anything questionable so that it goes in Outlook Junk mail. The "lost emails" I'm complaining about are not going into junk mail.

share|improve this question
add comment

2 Answers

First stop would be to enable protocol logging on the Receive Connector on your Exchange-server. To enable logging for all receive connectors on your server, use the following one-liner in the Exchange Management Shell:

get-receiveconnector | set-receiveconnector -ProtocolLoggingLevel Verbose

This will start generating logs of all incoming SMTP Traffic on your Exchange-server. You'll find this under "TransportRole" in the install directory on your Exchange server (dont' remember exactly which folder, but you'll find them)

Remember to turn off logging again using

get-receiveconnector | set-receiveconnector -ProtocolLoggingLevel None

Once you're done.

share|improve this answer
    
I've resolved this problem by setting up a rule in hMailServer that sends emails for "mydomain.com" directly to our Exchange Server, which is essentially bypassing the Sonicwall router. Do you have a suggestion for how I should close this question? –  HK1 Feb 8 '11 at 20:49
    
@HK1 - please post your solution as an answer, and then accept your own answer as accepted. –  Mark Henderson Feb 10 '11 at 20:40
add comment
up vote 0 down vote accepted

I've resolved this problem by setting up a rule in hMailServer that sends emails for "mydomain.com" directly to our Exchange Server, which is essentially bypassing the Sonicwall router.

Due to time constraints, I did not take the time to troubleshoot the issue any further to see where the problem was. It's interesting to me that the test emails sent prior to creating the rule, did come through after the rule was put in place.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.