Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

At work we have a Windows PPTP VPN server. I'm guessing it's an XP server, but I'm not sure and I'm not allowed to peek.

At home I have a Mac Mini running Snow Leopard. When I connect to the PPTP server at work, I can access all work machines, but at the same time I can browse the internet from my Mac. The traffic is not routed through the PPTP connection, because I would have noted the slowness. Apparently my Mac can figure out what to route where, automatically.

I also got this nice new Windows 7 laptop from my boss, which I use to connect to the same PPTP VPN server. When I do this, Windows tells me that the PPT connection is not used for internet, but it doesn't allow me to use the internet through my normal network adapter like my Mac does.

I have had it working once by writing down dns addresses and network ranges at the office, and then adjusting my routing table on the command line in Windows. I'm not even sure what I did, but I fiddled with quite some command line statements. Surely this can not be the way Microsoft intended this to work.

What is my Mac doing differently, and how do I tell my Windows 7 machine to do the same? I'd like to help a few colleagues out as well, and judging from the info I found on the interwebs, you'd be helping a lot of people with a simple sure-shot answer for dummies.

Additional interesting info you might need: My home network and laptop are a 192.168.x.x range The servers in the DMZ at work are in the 10.91.x.x range The servers in the internal network are in the 172.x.x.x range

At work (and on the mac when using vpn), the DNS name servers at work resolve all work addresses perfectly.

share|improve this question

2 Answers 2

You'll want to find and un-check the 'Use default gateway on remote network' option in your Windows 7 PPTP network connection settings. In XP this is found under the 'Networking' tab of the PPTP connection properties by highlighting TCP/IP in the list and hitting the 'Properties' button. Click 'Advanced' in the window that appears and make sure the 'Use the default gateway...' box is un-checked under the 'General' tab.

This should prevent your PPTP client from directing all traffic to the remote gateway and should let you browse the web and other resources not on the network you're connecting to.

share|improve this answer

I can't tell you for certain until I'm back on one of my VPN connections, but I would bet that the interesting routing tricks are being handled by ipfw.

Try "sudo ipfw list" from the command line both with and without the VPN connection made.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.