Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have several web development projects running on Fedora 13. I generally setup Apache to serve my larger projects as Virtual Hosts, but I've got several small projects cycling through that I don't really care to setup a VirtualHost for each one. Instead I'd like them all under a subdirectory of the main VirtualHost entry. I just want Apache to serve me the directory index when I browse to the host name.

For example, the hostname projects.mydomain.com refers to /var/www/projects, and that directory contains only subdirectories (no index file).

Unfortunately when I browse to the host directly I get:

Forbidden

You don't have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

But my virtual host entry in my apache config looks like this:

<VirtualHost *>
    ServerName      projects.mydomain.com
    DocumentRoot        /var/www/projects
    <Directory "/var/www/projects">
        Options +FollowSymlinks +Indexes
        AllowOverride all
    </Directory>
</VirtualHost>

What am I missing here?

share|improve this question

Check if there is something like this further down the configuration. It matches "/" and denies Indexing.

  <LocationMatch "^/+$">
        Options -Indexes
        ErrorDocument 403 /error/noindex.html
  </LocationMatch>
share|improve this answer
1  
Yes, this solved the problem! However, on CentOS 6.6, this part of configuration is located outside of main config file, in sub-direcotry /etc/httpd/conf.d/welcome.conf – Alexey Nov 16 '15 at 3:37

Try to add this:

    <Directory />
            Options +FollowSymlinks +Indexes
            AllowOverride all
    </Directory>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.