Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After a basic, successful installation of Oracle 11g, I ran dbca again to enable Enterprise Manager on my database. The operation hung at around 67% for half an hour or more, so I clicked Stop to abort the operation. Things seemed to wrap up cleanly, EM was working, all was well with the world.

Then I started getting this dreaded error upon any attempt to connect in SQL*Plus:

ORA-12154:
TNS:could not resolve the connect identifier specified

I thought perhaps the database had been corrupted due to the earlier aborted operation, so I ran dbca again and deleted the database. Then I attempted to create a new database in its stead, using a clone of the template created the first time around. Unfortunately, the clone database operation fails at 50% with the exact same error:

ORA-12154:
TNS:could not resolve the connect identifier specified

How can I clean up the mess I have created, short of reinstalling Oracle entirely from scratch?

share|improve this question

migrated from stackoverflow.com Feb 9 '11 at 1:10

This question came from our site for professional and enthusiast programmers.

4 Answers 4

ORA-12154 indicates that the tnsnames.ora file does not contain the appropriate entry for the database you are attempting to connect to.

share|improve this answer
    
At this stage in the game, no database exists... I'm trying to recreate it. –  nw. Feb 8 '11 at 20:48

What OS are you using? Are you using DHCP on your Oracle server with Windows? If so, read this about Loopback Adapters and Oracle.

share|improve this answer

When you get a hang setting up enterprise manager, it's almost always because it's trying to quiesce the database into exclusive mode. I'm not sure why it needs to do that but it does it. Any interactive sessions you might have open will hold it up.

As far as the tnsnames problem, find the tnsnames.ora file and see if it's messed up. The location depends on your OS. On Unix systems it's in $ORACLE_HOME/network/admin/tnsnames.ora by default. I don't run Oracle server on Windows, so I'm not sure what the path is for that. It could have some half written junk in there from the abort that is preventing it from working when it adds the new database.

share|improve this answer
up vote 0 down vote accepted

The problem seems to have been a nonconforming password. Using characters other than alphanumerics, #, $, and _ in your Oracle password will cause this error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.