Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I m currently on Ubuntu 10.04

$ uname -a
Linux dpn2 2.6.32-27-server #49-Ubuntu SMP Thu Dec 2 02:05:21 UTC 2010 x86_64 GNU/Linux
$ ldd --version
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.04.1 LTS
Release:    10.04
Codename:   lucid
ldd (Ubuntu EGLIBC 2.11.1-0ubuntu7.7) 2.11.1
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

I need to upgrade to EGLIBC 2.12.x. I can do this by doing a distro upgrade but is there any other way?

share|improve this question

1 Answer 1

Not in Ubuntu, no. If you're willing to replace such a critical package, Linux From Scratch project might be a better idea.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.