Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a really old Video learning program that we need to run from the network for our students. However it uses Director Player 6.0 and the students get the error: "Unable to copy the driver file C:\Windows\xobglu16.dll to your Windows directory. Your disk may be full"

Now the solution I've read is to copy the files manually to each machine and mark them read-only.

I'm trying to do this via GPP, but the Event log is showing an Access is denied error. I believe it is because the student accounts do not have permission to c:\windows.

Any ideas on a work around without using a script?

share|improve this question
4  
Is there some reason why you aren't apply a computer policy, which operates in the system context? –  Zoredache Feb 9 '11 at 16:25
    
I have tried it in a computer policy and User. Both give me the same error. "The computer 'xobglu16.dll' preference item in the 'TEST - CMP - Secondary Software Deployment Group Policy object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed." –  Fireshot Feb 9 '11 at 19:33
    
So I managed to solve the problem. For some reason the folder on the network share was not inheriting permission so the students didn't have access to the file... It was a complete bone headed move on my part to not notice that right away. Thanks for all the help guys. –  Fireshot Feb 18 '11 at 14:54

3 Answers 3

There is no way to do this with Group Policy. Your options are:

  1. Write a script to copy from the network folder, however depending on your setup you may need to give your students access to write to C:\Windows

  2. Push the file via an SMS package or another automated software delivery system.

share|improve this answer
    
Please see sysadmin's comment that suggests otherwise. In the GPP option, see: "Run in logged-on user's security context (user policy option)" changes the default user context. Normally preferences are processed using the Local System account (SYSTEM), selecting this option will make sure the user context is used instead. Network Drive and Printer Mappings ignore this setting as they always use the user context anyway. –  tegbains Feb 9 '11 at 19:23

Make sure you haven't checked the "Run in user security context" box on the files you're pushing out. That would be on the "common" tab in GPP. If that is unchecked and you're still getting the error, it would be a very good idea to try and get this pushed out through the Computer GPP. Since these are probably student machines, they're likely in an OU that's full of them anyway.

share|improve this answer
    
Run in user security context is not check. I have tried running it in a computer preference and a user preference both fail. The error I get on the client Event log is: "The computer 'xobglu16.dll' preference item in the 'TEST - CMP - Secondary Software Deployment Group Policy object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed." At least on the share side I am 100% positive that the correct permissions are in place. –  Fireshot Feb 9 '11 at 19:32

You need a 2 step process:

  1. Copy the file(s) from the network share to %UserProfile% using the "Run in logged-on users's security context (user policy option)"
  2. Copy the file(s) from the %UserProfile% to C:\Windows making sure the "Run in logged-on users's security context (user policy option)" is NOT selected

This works for me....

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.