Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On my new vps.net server .htaccess does not work. mod_rewrite is what the .htaccess is trying to do.

These are the steps I have done so far:

Added:

<Directory "/var/www/*">
    Order allow,deny
    Allow from all
    AllowOverride All
</Directory>

To /etc/apache2/apache2.conf

Restart apache. /etc/init.d/apache2 restart

No luck.

Verified the .htaccess is actually there, it is.

Verified my apache2.conf has the line AccessFileName .htaccess, it does.

Edited /etc/apache2/sites-available/default

Changed:

DocumentRoot /var/www
<Directory />
       Options FollowSymLinks
       AllowOverride None
</Directory>
<Directory /var/www/>
       Options Indexes FollowSymLinks MultiViews
       AllowOverride None
       Order allow,deny
       allow from all
</Directory>

to:

DocumentRoot /var/www
<Directory />
       Options FollowSymLinks
       AllowOverride All
</Directory>
<Directory /var/www/>
       Options Indexes FollowSymLinks MultiViews
       AllowOverride All
       Order allow,deny
       allow from all
</Directory>

Restart apache. /etc/init.d/apache2 restart

No luck.

Do not know what to try next?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Does rewrite.load appear in /etc/apache/mods-enabled/?

If not, does it appear in /etc/apache/mods-available/?

If it's in the latter and not the former, a2enmod rewrite and another restart of Apache should set you on your way -- this just creates a symlink in -enabled to the file in -available which tells Apache to load that module.

If that doesn't work, do you get anything in /var/log/apache/error.log (or wherever your Apache instance logs its errors?)

share|improve this answer
    
Thank you so much! this solved it. :) –  JD Isaacks Feb 9 '11 at 20:21
    
Oh, excellent. Ignore my edit about error logs then :-) –  James Green Feb 9 '11 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.