Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to change the directory that is served up by the service. So I have changed the httpd.conf file:

# DocumentRoot "C:/IBM/HTTPServer/htdocs/en_US"
DocumentRoot "C:/sites"

#<Directory "C:/IBM/HTTPServer/htdocs/en_US">
<Directory "C:/sites">

But stopping and starting the service doesn't change the directory that is served up.

Any ideas?

share|improve this question

2 Answers 2

Wait for the server to reload it's cache.

share|improve this answer

In your configuration directory, look for the sites-enabled folder, in there should be a file called 000-default or something similar; this is where you should be changing your document root. The settings in this file override the ones in httpd.conf.

This is where it is for Apache2, though I noticed you have your post tagged with IBM WebSphere. I have never deployed, or administered, WebSphere; this is mostly just a suggested place to look.

share|improve this answer
    
I think it's like most IBM tools... it's an open source project with a few IBM features to call there own. –  NitroxDM Feb 10 '11 at 14:57
    
Okay, sweet! In the directory where httpd.conf is kept, is there a sites-enabled directory? –  nesv Feb 10 '11 at 15:48
    
There isn't. But I checked the server again today without making any changes. It's serving up the correct directory now. I must have been looking at a cache. :( –  NitroxDM Feb 11 '11 at 20:44
    
sites-enabled/ is unique to the debian-style packaging of Apache HTTP Server. –  covener Jul 3 '11 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.