Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Got a Postfix-Dovecot-Saslauthd setup on Ubuntu 10.04.

Problem is there's (at least) one domain that it refuses to accept emails from. I've been getting emails fine from lots of different domains except one. It's really weird, but could some config file or something be blocking certain domains? or IPs? or something? I know the emails are being sent to me, infact I sent a test one myself from this domain and they're just not showing up.

share|improve this question

4 Answers 4

up vote 0 down vote accepted

Do not look in logs for the senders domain name, it is probably rejected before the domain name had a opportunity to appear.

Launch a tail -f on the mail.log and send the test email.

tail -f /var/log/mail.log

Look for any connections that are rejected and for a reasons. The log entry does not have to include the senders domain name, because the sender's smtp server was probably rejected before it had a chance to send "mail from:" command. It could be dropped because of ehlo header, ip, or other rule. It must be there somewhere in the log.

Does the sender's domain has proper dns configuration? mx? any openspf entries? Does the sender's smtp has reverese dns entry?

If there is no connection initiated in the logs, that means the sender's server didn't even try to send the mail. Does your domain has proper dns configuration? Are the MX entries valid?

dig domainname
dig domainname mx
dig domainname txt

Or maybe the sender's domain is configured as local destination in your postfix?

You did not provide any real domain names, so we can't check anything, and it is really impossible to guess. There is a lot, a lot, of reasons for not receiving emails.


The dns entries for both domains look correct. Look for ip of the senders domain smtp server (74.220.207.174) in your /var/log/mail.log

share|improve this answer
    
Thanks for your answer. I'm fairly new to unix commands so how to I launch a tail -f on the mail.log? I think the sender's domain has proper dns and mx configuration, but how do I check? My domain is: onlythebible.com, the problem domain is: doanddare.org –  Emmanuel Feb 12 '11 at 19:07
    
@Emmanuel: Launch in console: tail -f /var/log/mail.log it will show 10 last lines from the file, and then every new line that is appended to it. –  silk Feb 12 '11 at 21:16
    
Thanks again. Tried the tail -f command and sent an email from the problem domain (doanddare.org), but not a single thing changed in the mail.log file. I also searched mail.log for the ip 74.220.207.174 but the only references to it were emails I had sent (from my domain) to it, which went through fine. –  Emmanuel Feb 13 '11 at 1:59
    
@Emmanuel: I would say everything looks fine on your end. You should try to contact admin of doanddare.org and ask him to check why his smtp server is never trying to connect to yours. –  silk Feb 13 '11 at 12:12
    
Okay, I'll do that. Thanks everyone for your help. –  Emmanuel Feb 14 '11 at 4:55

Did you already tried searching in your configuration for that domain?

grep -ri blocked.domain /etc/postfix

Did you check your logfiles?

less /var/log/mail
share|improve this answer
    
grep -ri my_problem_domain.tld /etc/postfix didn't return anything. Yes I'd already checked the log files, there's absolutely no reference to the problem domain being rejected or even that the emails have been received. –  Emmanuel Feb 10 '11 at 18:20
    
You wrote you can send yourself mails from that domain, don't you get any error mails back? Can you check if the mails have been sent at all? Have you access to the mail queue and/or log files on the sending side? –  rems Feb 10 '11 at 18:45
    
Mm... Good point. I'll have a look to see if I can get hold of the log files on the sending side –  Emmanuel Feb 10 '11 at 19:01
    
Well, I can't get hold of the log files. But I'm certain the email is being sent because I just sent another test email to multiple addresses, and the email was received on all of the addresses except to the address on my mail-server. –  Emmanuel Feb 10 '11 at 19:07

In addition to what pietrocat told, check if the mailserver of that problematic domain is listed on some RBLs (this will only affect you if your mailserver uses RBLs to block e-mails):

  1. dig mx problem-domain.org
  2. Get the IP address: host xyz.problem-domain.org
  3. Search for that IP on http://www.mxtoolbox.com/blacklists.aspx and http://www.robtex.com
share|improve this answer
    
Yes, I thought something like this could have been a problem. But I don't think my mailserver uses RBLs to block emails. At least I haven't set that up, unless it was done automatically. But now that I've checked, it doesn't appear as though the server ip has any blacklisting. link and link –  Emmanuel Feb 10 '11 at 18:27

Check the log /var/log/mail.log to see what happens. So you can have more info to solve the problem.

share|improve this answer
    
Yes I'd already checked the log files, there's absolutely no reference to the problem domain being rejected or even that the emails have been received. –  Emmanuel Feb 10 '11 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.