Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I change the output of just the domain name (including the trailing slash (/), of course)? I'd really like the URL to end at the domain name rather than having an ugly index.html there.

To further explain: Apache is returning the page just fine when the WWW-qualified URL is used (e.g., but when just domainname.tld ( is used, it just gives the "It Works!" message.

share|improve this question
What OS or Distro are you on? Is it an install from source or from a package? – Niall Donegan Feb 10 '11 at 10:35
running a fresh amazon ec2 ubuntu ami, Apache 2.2.17. I installed with zero options (even left PREFIX at default). It sounds like others have been helped by the advice others have given, but in my case: I can't find a welcome.conf (sudo find fails me!), OR an /etc/apache2 directory. – invaliduser Feb 10 '11 at 17:35

Either add an index file in the document root, or rename welcome.conf in the configuration directory to something that the configuration files won't pick up.

share|improve this answer

I think you can control this from the config file


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.