Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'd like to start learning WWW-programming in my Linux Mint. I have installed PHP and now I'd like to install MySQL. I tried to follow instructions on http://www.cyberciti.biz/faq/install-mysql-server-5-on-ubuntu-linux/ but I got the following error message:

sudo /etc/init.d/apache2 restart
* Restarting web server apache2
apache2:    Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

... waiting .apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

What am I doing wrong? And how can I install Smarty on my computer?

share|improve this question

1 Answer 1

Define a variable ServerName in your http.conf file. When a name isn't defined apache uses 127.0.0.1(loopback) address as the server name.

This is not an error and apache is running despite through these.

share|improve this answer
    
Strange. It looks like I don't have http.conf in my computer. –  Beginner Feb 10 '11 at 12:12
    
Linux Mint is Ubuntu based, meaning your config file will be /etc/apache2/apache.conf. –  JamesHannah Feb 10 '11 at 12:33
    
So, you can find /etc/apache2/apache2.conf –  Khaled Feb 10 '11 at 12:34
    
Okay. Now I added lines # This would be correct. <VirtualHost *:80> ServerName some.domain.com # Options and stuff defined here. </VirtualHost> which I found by Google. But it still won't work. –  Beginner Feb 10 '11 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.