Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am starting off with Windows deployment services, but get stuck at the very first step. I login as local administrator to the windows server (FYI it is not the domain controller nor the dhcp server) and navigate to windows deployment services. When I try to expand the Server snap in - I get an error message dialog box saying "One or more servers were not added in due to errors". If I try to add a server, it says "You must be an administrator to add a server to the snap in". Ok so may be because its a local admin that's why I get this error? So I login with an AD\admin account where it shows the complete tree in the the WDS server administrator window. No errors, and I proceed to add a boot image from the local directory with Full control(file permissions) for the SYSTEM and administrator. Everything proceeds properly just before the final stage when I get an error saying

Access is denied

So I tried from the command prompt with wdsutil :

WDSUTIL /Add-Image /ImageFile:"E:\wds\boot.wim" /ImageType:Boot

only to get

Error Code: 0x52B
Error Description: The credentials used while attempting to execute this command
were invalid. Ensure that you are logged on with a domain user account and try
the operation again.

which is pretty weird as the accounts have Full control. Tried doing a runas with both the admin accounts but ... :/

Where am I going wrong and where can I check to find more debug information? Thanks in advance for any help ....

share|improve this question

1 Answer 1

Try this out:

Uninstall WDS

Create a new service account for WDS

Add the service account to local admin of the server

Log in as the user

Reinstall WDS

share|improve this answer
    
Thanks pablo... my colleague just noticed it worked with her id and adding my id to the admin user group allowed me to get going. However, the local admin still can't do it. I guess its one of the requirement of the account to be domain authenticated (or something of that sort ...) –  Tathagata Feb 15 '11 at 17:39
    
Glad you got it working. –  pablo Feb 15 '11 at 17:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.