Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Exchange 2010 organization installed at two sites with one server at each site. I set up my local site first. Exchange Management Console always chooses to connect to the remote server instead of a local one. I can open the properties of "Microsoft Exchange On-Premises (remotemail.example.com)" and tell EMC to connect to the local server, but it ignores the request and stays connected to the remote server.

How do I get EMC to default to the local server, and why can't I change which server it connects to?

share|improve this question

4 Answers 4

up vote 0 down vote accepted

You can try this approach or check the bindings in the Default WebSite in IIS. Is should point to "All Unassigned". Please read-through this article as well.

share|improve this answer
    
That wasn't it, but it did point me in the right direction. I got an actual error message when I fired up the Exchange Management Shell (thanks MS for hiding the error in EMC). –  Craig Putnam Feb 10 '11 at 17:40

This discussion provided the answer. When I started Exchange Management Shell, it attempted to connect to the local server and failed with the message:

The system load quota of 1000 requests per 2 seconds has been exceeded

I followed the quick-fix advice of running iisreset, and it appears to be working at the moment. If the issue reoccurs, I will change the PowerShellMaxCmdlets and PowerShellMaxCmdletTimePeriod properties using Set-ThrottlingPolicy.

share|improve this answer
    
When this happens in the future, you can just recycle the MSExchangePowerShellAppPool app pool so you don't disrupt client access. –  Jeremy Lyons Aug 2 '13 at 3:23

Under C:\users\xxxx\AppData\Roaming\Microsoft\MMC\ there is a config file named Exchange Management Console. Delete it. In the registry under HKEY_CURRENT_USER\Software\Microsoft\ExchangeServer\v14\AdminTools: clear the value for "NodeStructureSettings".

share|improve this answer

If the EMC is pointing to a wrong on-premises server then go to C:\Users\username\AppData\Roaming\Microsoft\Exchange\RemotePowerShell and change the folder which is located inside RemotePowershell or Delete the exchange folder itself as suggested above. And then proceed to the registry edit. Before making any changes to registry ensure the whole resgistry is exported to the desktop and then proceed to make changes in HKEY_CURRENT_USER\Software\Microsoft\ExchangeServer\v14\AdminTools: clear the value for NodeStructureSettings on the left side only few 0000s will be left which you cant delete anyways. Close and relaunch EMC and it should point to the correct server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.