Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Been seriously racking my brain for a while with this.

I'm trying to add a Virtual Directory to a site that points to a UNC share. Both machines are not in a domain and I know the machines both see each other.

I've read that I need to create a user account on both machines with the same user name and password. For the VDir I have set the Specific User in the Connect As dialog and set the Physical Path Credentials Logon Type as "Network." If from the Basic Settings Dialog I run "Test Settings..." Authentication and Authorization both check out ok.

If I try to browse to the virtual directory with http through my site to access a simple graphic, I get a 500 error. Despite turning on all the detailed error message, trace logging - none of the sub error code (500.xx) comes through.

The VDir points to another website on another server that has it's own Web.Config. I had thought that perhaps that Web.Config was getting in the way but when I temporarily removed it, there was no change.

Currently, the App Pool assigned to the site has the Identity set to ApplicationPoolIdentity. I had tried NetworkService, and I tried using a custom account with the same user name and credentials as the accounts that are on both machines

Not quite sure what's left to try or do differently but I hope I've supplied enough information.

I appreciate any input in advance!

EDIT: Strangely enough, I'm seeing on the server with the share, that there's a login from ANONYMOUS LOGON from the Security Event viewer. Then an immediate Log Off...

share|improve this question
    
Does your IIS Anonymous account have permissions set on the vdir? –  Antonius Bloch Feb 10 '11 at 22:50

1 Answer 1

up vote 0 down vote accepted

BINGO! I got it.

Hit the Advanced Settings for the Virtual Directory - Physical Path Credentials Logon Type was set to "Network" because well, that had made sense I guess. I changed it back to the default of Interactive and all seems to be fine.

Same User Name on both machines. Same passwords for each user.

That seemed to do it. Hopefully this thread comes up on Google to help some poor sap that struggled with this problem...

Thanks for all who looked at this thread and gave it a thought!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.