Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to new user that can sftp on a server....i did this

ubuntu@ip-10-112-46-15:~$ sudo useradd jesse -p testPass
ubuntu@ip-10-112-46-15:~$ sudo passwd jesse
Enter new UNIX password: 
Retype new UNIX password: 
passwd: password updated successfully

but when i try to login via sftp I cant get in....am i missing something like adding a group or something

the answer was

PasswordAuthentication yes
share|improve this question
    
Fort he record, you would find that adduser is much easier to use for creating users. –  Zoredache Feb 11 '11 at 7:00

1 Answer 1

up vote 2 down vote accepted

"I can't get in" isn't terribly descriptive. What is the error?

Why did you give the user a password, and then change it right away?

The easiest way to debug it is to run sftp in verbose mode:

sftp -vv jesse@remotehost

You might not have a valid shell, you might have AllowUsers or AllowGroups in sshd_config, you might be giving the wrong password, you might have password logins turned off...on and on. We need some more info.

share|improve this answer
    
sftp -vv jesse@host -pftplogin Connecting to 889... OpenSSH_5.2p1, OpenSSL 0.9.8l 5 Nov 2009 debug1: No more authentication methods to try. Permission denied (publickey). Connection closed –  Matt Feb 11 '11 at 3:24
    
why do is permission denied if i have my password –  Matt Feb 11 '11 at 3:25
    
i need to give someone ftp access to add files so they wont have the key –  Matt Feb 11 '11 at 3:26
    
where is teh place to check if password logins is turned off –  Matt Feb 11 '11 at 3:29
1  
You want: "PasswordAuthentication yes" and "UsePAM yes" in sshd_config. –  James Cape Feb 11 '11 at 4:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.