Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have PostgreSQL 9 running on Windows 2003 SP2. I am trying to replicate it on a Fedora 12 system running PostgreSQL 9 as well.

I am hitting this error message:

/usr/pgsql-9.0/bin/postgres -D /var/lib/pgsql/9.0/data/ -p 5432
2011-02-11 17:43:26 ISTFATAL:  incorrect checksum in control file

Because of firewall restrictions, I could not follow the official instructions to the letter. Instead, I zipped the contents of the data directory when the server was offline and copied that to the Linux box. I ran a sha1deep on both directories and there were no mismatches. I changed the rights so that only the postgres user and group had access to the files.

Now, what can I do for replication to work? I tried with a 'pg_dumpall', but the system complains that the database IDs do no match.

share|improve this question
    
Are you sure your Linux machine is the same architecture as your Windows one? –  Milen A. Radev Feb 11 '11 at 8:14
add comment

1 Answer

To use streaming replication, you have to use the same PostgreSQL versions on the same operating systems. Windows and Fedora are different OS's, that is not going to work for streaming replication.

If you want replication between different versions and/of different OS's, you could take a look at Slony.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.