Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A while back I opened a thread for this on the WinSSHD form, but never followed up until now. I then was able to reproduce this locally via the farmanager console.

Very simply, if I start up sqlcmd in a vanilla cmd.exe (windows 7) it behaves in the traditional "insert" mode. If I type some text, move the cursor to the left and type over it, the newly inserted text will move the text to the right of the cursor to the right. If I ssh into my remote server (Windows 2008) and do the same the console goes into overwrite mode whereby the text I type overwrites text to the right of the cursor. This only happens in sqlcmd, and not from a regular cmd.exe or powershell prompt. If I hit the "insert" key on my keyboard when running sqlcmd over ssh the expected insert/overwrite behavior is exhibited. However, each time I hit enter inside of sqlcmd the console reverts to overwrite mode.

Yesterday I discovered the same "revert to overwrite" behavior occurs if I run sqlcmd locally from inside Farmanager v2.0 build 1807 locally. Farmanager does not seem to have a propensity towards overwrite mode otherwise. I linked to this question on their forum.

share|improve this question
up vote 1 down vote accepted

When you come across the problem again, click on the upperleft of the sqlcmd window (to the left of the window's title). From the drop-down, choose Defaults and click Insert Mode. Do the same for Properties (also from the drop-down box). You might want to also enable Quick Edit mode. With Quick Edit mode, you can hightlight text and then hit enter to have the text copied in to the copy/paste buffer.

share|improve this answer
That seems to work for farmanager. However, it cannot work for winsshd since I don't have access to the properties menu of the hidden cmd.exe created on the server when I run putty. The problem with setting that in far is that far unsets that and insert mode. – Justin Dearing Feb 11 '11 at 17:51
I am stumped. My only other suggestion is to check the WinSSHD forums and/or contact their support. – jftuga Feb 11 '11 at 18:33
Already did Perhaps they will discover something. – Justin Dearing Feb 11 '11 at 19:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.