Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to try mounting a folder with NFS - I set up the NFS sharing on a windows 2008 R2 server, specified hosts in the NFS permissions (by IP address) and mounted via /etc/fstab

it mounts, but when I try to list the folder, I get 'input/output error'

the owner/group on the local mount point look weird too?

drwx------ 2 4294967294 4294967294 4096 2011-02-10 19:15 data/

I mounted in /etc/fstab as:

10.0.6.55:/share$ /media/data nfs soft,intr,rsize=8192,wsize=8192

What am I doing wrong?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

The issue was on the Windows Server side and it could not map the unix account to AD.

This blog post+comments led me to the solution.

http://blogs.msdn.com/b/sfu/archive/2007/04/19/mounting-nfs-share-on-nfs-client.aspx

share|improve this answer

UID/GID mapping can be messed up, but you could try and chown the mount to yourself

share|improve this answer
    
tried mounting with a specific gid/uid, didnt work. any other ideas? –  pablo Feb 14 '11 at 20:10
    
I meant mount as root, and then chown the mount to root –  dyasny Feb 14 '11 at 20:55
    
tried that no luck same issue. –  pablo Feb 15 '11 at 11:54
1  
can you post how you configured the NFS in windows? especially the NFS share screenshots –  dyasny Feb 15 '11 at 13:32

In the NFS settings in windows NFS Share settings, checking allow Unmapped users access radio box allows it to work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.