Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

here's a new one for me, and my first time posting here:

I installed VMWare workstation 7.1 on a new PC. VMWare properly installs the virtual network adapters under the Network Connections control panel, however for some reason they do not show up under ipconfig, which is very weird. They also don't appear anywhere in "route print". I don't have network connectivity to the VM.

My guesses are perhaps some conflict with Symantec AntiVirus or Symantec Client Firewall.

Tried the following things:

  • enabling TCP/IP in the virtual network adapters (they often get installed with it disabled for some reason)
  • Restoring defualts in the VMnetcfg gui tool (this causes an uninstall and reinstall of the virtual network adapters on the host)
  • Re-installing vmware workstation
  • Uninstalling checkpoint secureremote and then reinstalling vmware

Just to be clear, this problem is totally on the host.

In my searching for stuff about (non-vmware) adapters missing from ipconfig, I see some posts about resetting the TCP/IP stack using netsh. Looking into that next...

Thanks!

share|improve this question
    
I removed 2 networking protocols and did restore defaults in the vmware network tool, and that seemed to resolve this problem. For good measure I disabled antivirus and firewall. The 2 protocols were: Cisco Discovery Protocol Packet Driver and iPass 802.1x. These were removed by uninstalling a Cisco Voip softphone and iPass client software (for logging into pay wifi networks). Both were part of the standard build on this PC, and luckily I didn't need either. Perhaps reinstalling them after VMware would work if I needed them. Hope somebody finds this helpful! –  aberson Feb 12 '11 at 6:36

3 Answers 3

The answer by @Adam works for me.

To add to it, the VMnetcfg tool referred by is not available by default in VMWare installed dir.

To get it,

  1. Run the installer with /e option. For example:

VMware-player-4.0.4-744019.exe /e .\extract (all contents will be extracted to "extract" folder)

  1. Extract vmnetcfg.exe from "network.cab" in "extract and copy vmnetcfg.exe to your installation folder (like "C:\Program Files\VMware\VMware Player\")

  2. Run it after uninstalling "Cisco Discovery Protocol Packet Driver" and click "restore defaults".

share|improve this answer

I guess to mark this question as answered, I need to post an answer, not a comment...

Below is the resolution that worked for me. I hate having any extra networking protocols/bindings, they always seem to cause impossible-to-troubleshoot networking problems like this.

I removed 2 networking protocols and did restore defaults in the vmware network tool, and that seemed to resolve this problem. For good measure I disabled antivirus and firewall. The 2 protocols were: Cisco Discovery Protocol Packet Driver and iPass 802.1x. These were removed by uninstalling a Cisco Voip softphone and iPass client software (for logging into pay wifi networks). Both were part of the standard build on this PC, and luckily I didn't need either. Perhaps reinstalling them after VMware would work if I needed them. Hope somebody finds this helpful!

share|improve this answer
    
ok, now waiting 2 days to be able to accept my own answer :) –  aberson Feb 12 '11 at 6:45

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1008367
http://www.google.co.in/search?aq=0&oq=trouble+shooting+vmware+ne&sourceid=chrome&client=ubuntu&channel=cs&ie=UTF-8&q=troubleshooting+vmware+networking

share|improve this answer
    
thanks for your suggestions. Unfortunately, most vmware networking problems are focused on some improper settings, people not understanding bridging, etc. In this particular case, the vmware network adapters on the host were not even showing up under the host's ipconfig... a topic which provided me with few to no results after several hours of searching. –  aberson Feb 12 '11 at 6:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.