Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I created a kickstart file ks.cfg and then I have put that in the bootable disk*(Ubuntu 10.04)* and then added the following line to the isolinux.cfg linux ks=ks.cfg and have not removed any other lines from the isoconfig.cfg file and then while installing the installation is not automated,again it is asking for language and all.

If i removed include menu.cfg or any other line from isolinux.cfg i am getting a boot error.

What should i do now to automate the installation.Where should i add the boot parameters so that installation will start from the ks.cfg .

Thanks and Regards Ravi Kumar

share|improve this question

2 Answers 2

Where is your ks.cfg located ? You should define the "ks" parameter with a URL, like "ks=http://192.168.1.10/ks.cfg"

share|improve this answer

in my opinion your installation does not see the ks.cfg file. Maybe you should specify the absolute path: ks=/cdrom/ks.cfg or so. From here :ks=cdrom:/path/to/ks.cfg is the right syntax. Personally, I was disappointed with Ubuntu's kickstart implementation and went using preseed.

share|improve this answer
    
Hi, I have given the absolute path,even then the installation is not automated..Its still happening in the normal way. –  user70523 Feb 14 '11 at 11:23
    
You need to use the Alternate ISO, not the regular one. This might be the problem. Can you make sure you use the correct ISO? –  grs Feb 19 '11 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.