Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server, called Server1 with various network shares on it. Our users map to this share using \\Server1\FileShareName1.

During a DR Test, we rerouted all network traffic from Server1 to Server21. All folder shares are set up on Server21.

We were hoping the the network shares would still be accessible using \\Server1\FileNameShare1, unfortunately, they are not.

Does anyone know why this is happening?

This is a Win2003 Environment, and DNS was flushed. I confirmed that IP addresses are matching between the two servers.

Any help or insight is much appreciated.

share|improve this question
    
Forgot to mention, also getting this error when connecting to the share via windows explorer "Logon Failure: The target account name is incorrect" –  Justin Largey Feb 12 '11 at 15:19

1 Answer 1

up vote 3 down vote accepted

I'm assuming that you're creating a CNAME record for Server1 that points to Server21 or that you're changing the A record for Server1 to point to Server21's ip address. In either case you need to disable strict name checking on Server21:

http://support.microsoft.com/kb/281308

share|improve this answer
2  
I agree with joe's answer but to add to that take a look at Windows DFS, this will allow you to keep path names the same and switch the back end server as you see fit. –  pablo Feb 12 '11 at 15:10
    
Rats. I meant to mention that DFS would be a better alternative, but forgot. Thanks for mentioning it pablo. –  joeqwerty Feb 12 '11 at 15:14
    
Thanks for the feedback, I will look into it. Also, I forgot to mention that I'm getting this error when attempting to connect to \\Server1, "Logon Failure: The target account name is incorrect", is this an active directory thing? –  Justin Largey Feb 12 '11 at 15:18
    
That's normal. There's a trick too, just go \\10.2.2.1\sharename, where 10.2.2.1 is your server and sharename is your share. It should work, and once you apply the reg change joe posted that should be all but fixed. –  pablo Feb 12 '11 at 15:21
    
Thanks for your help, worked like a charm! –  Justin Largey Feb 14 '11 at 16:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.