Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I changed the nameservers for my domain name veeter.com about 5 days ago now - and the domain is still not resolving over the net.

It does intermittently, but then cuts out again every few hours.

I run 10+ other domains through the same dedicated server (running CentOS/WHM) and they are all up - so it has nothing to do with that.

I have asked my dedicated server support staff what the problem might be, they told me to "log into WHM and click on 'Add a DNS Zone' under the 'DNS Functions' section on the left hand side of the screen. Once you have done this and dns fully propagates it should resolve any intermittent dns issues you may be experiencing."

BUT there is already a DNS zone in place for the domain on my server - so what should I do?

My server host has gotten back to me finally stating it is most likely a problem with my ISP's caching mechanism and I should contact them - but somehow I doubt it - never noticed this problem before (and I migrate a lot of nameservers).

share|improve this question
    
can we get the domain to test please? –  Jacob Feb 12 '11 at 20:43
    
Yes sorry guys - it's actually veeter.com - I meant to say "changed the nameservers FOR veeter.com", not "to veeter.com" :S –  darkAsPitch Feb 13 '11 at 5:21
add comment

3 Answers

It's pretty hard to troubleshoot this without the actual domain name (which I can understand your not wanting to give here). Without a domain name all I can advise you to do is:

  1. Check at the GTLD servers to see if they know the correct NS's for your domain
    (Try a few of them)

  2. If the GTLD servers know the correct nameservers, ask some public DNS servers and see if they do too.

  3. If public DNS servers have the correct NS records they should be able to resolve stuff in your domain -- if not (or if it is intermittent) investigate your authoritative DNS servers to see what they're doing.

5 days should be more than sufficient for any DNS propagation -- 24 hours is usually plenty of time. My suspicion is you have nameservers specified incorrectly somewhere or your authoritative servers are broken in some way...

share|improve this answer
2  
If you have access to dig, you can pass the +trace option and use 4.2.2.2 as the name server. It will illustrate the steps it takes to resolve your domain, which in turn can help pinpoint a breakdown. The command you could use would be along the lines of: "dig +trace www.veeter.com @4.2.2.2". There are also some web based tools available to check your zone. First one that comes to mind is dnscog.com. –  mcmeel Feb 12 '11 at 21:06
    
+trace is definitely a good way to accomplish the above steps in one command :) –  voretaq7 Feb 12 '11 at 21:07
1  
The report at dnscog has some helpful information. You can view it here: dnscog.com/report/veeter.com –  mcmeel Feb 12 '11 at 21:27
    
I run windows 7 and various linux boxes here at my home, so I should have access to dig (it's a linux command?) –  darkAsPitch Feb 13 '11 at 5:23
    
Yeah, dig is a linux utility, preferred over nslookup. –  Ward Feb 13 '11 at 7:23
add comment
up vote 1 down vote accepted

mcmeel actually answered this for me - so feel free to edit yourself in as the author or whatnot...

mcmeel pointed me to dnscog.com - which gave me a report for my domain, stating that it was indeed attached to the "old" nameservers I once used on my server.

Basically what happened was... when I first used WHM I had setup some custom default nameservers. A few months later, I changed them - but now whenever I create a new account through WHM it binds the domain to the old nameservers :S

(Anybody who can help me change the "default nameservers" used when setting up a new domain through WHM will get an upvote from me!)

share|improve this answer
    
blog.eukhost.com/webhosting/… take a look there I think thats what you need. –  Jacob Feb 13 '11 at 23:40
    
voretaq7's technique is correct, I simply provided some tools to help accomplish the steps he outlined. Glad to have helped! –  mcmeel Feb 14 '11 at 5:15
add comment

Use dig @localhost ANY +trace veeter.com, or go to use kloth's dig service. It returns:

dig: couldn't get address for 'one.hostril.com': failure

veeter.com. 172800 IN NS one.hostril.com.

veeter.com. 172800 IN NS two.hostril.com.

;; Received 104 bytes from 192.55.83.30#53(m.gtld-servers.net) in 133 ms

Is that a typo?

share|improve this answer
    
strange I get 64.150.186.228 –  Jacob Feb 14 '11 at 2:09
    
Using domaintoip.com, I get 64.150.186.228, which has a reverse of abac.net. However, dig still returns the misspelt nameservers. –  Victor Feb 14 '11 at 2:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.