Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to write an upstart script to start orbited on startup. The script is as follows:

#orbited
start on startup
stop on shutdown
script
        exec /usr/local/bin/orbited --config=/etc/orbited.cfg
end script

When I run upstart orbited I get something like this:

orbited start/running, process 605

But when I run status orbited right after doing that I get:

orbited stop/waiting

The script fails to start even though it says it's running. Any ideas?

Thanks!

share|improve this question
    
What do your logs say? –  Dennis Williamson Feb 13 '11 at 9:18
    
I figured out through the orbited logs that it was exiting with an error. There was no user called "orbited." I fixed that and it will now start when I manually send "start orbited" but it's not starting automatically on bootup. Progress is progress anyway. –  Holy Crap Feb 15 '11 at 4:59

1 Answer 1

You might want to remove exec from your script. It does the same thing as putting the script brackets. Should look like

script
     /usr/local/bin/orbited --config=/etc/orbited.cfg
end script

Hope this helps

share|improve this answer
    
Thanks for the reply. I just tried that and it's still behaving the same way. –  Holy Crap Feb 15 '11 at 4:40
    
Okay, I figured out that it wasn't starting because orbited didn't have a user set up in the config file. Now it'll start when I tell it to in the upstart script, but it won't start automatically on bootup. –  Holy Crap Feb 15 '11 at 4:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.